Rails 3.1 error – Could not find a JavaScript runtime?

最近不小心升到 Rails 3.1 因此在建立新專案時又TMD爛掉了!?

有沒有Ruby on Rails 每次升級就爛掉的八卦?!ヽ(`Д´#)ノ ムキー!! (冒青筋

[cc lang=”bash”]
$xyz rails s
/home/XXX/.rvm/rubies/ree-1.8.7-2011.03/lib/ruby/gems/1.8/gems/execjs-1.2.9/lib/execjs/runtimes.rb:47:in `autodetect’: Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)
[/cc]

解決方法,到Gemfile新增兩行:
[cc lang=”ruby”]
gem ‘execjs’
gem ‘therubyracer’
[/cc]

然後bundle install

總算暫時平息 〜( `д´)b オッケー!